Opened 7 years ago

Closed 7 years ago

#6318 closed (duplicate)

Changing contrib.auth.views to use newforms

Reported by: Shabda <shabda.raaj@…> Owned by: shabda
Component: Contrib apps Version: newforms-admin
Severity: Keywords: auth, newforms
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

==Changing contrib.auth.views to use newforms==
django.contrib.auth.views still is using the oldforms library. I have modified the files django\contrib\auth\views.py and django\contrib\auth\forms.py to use the newforms library, since the transition to newforms is being done against the newforms-admin branch, i have created a patach on newforms-admin branch, revision 6996.
==Issues==
# Template admin/auth/user/change_password.html, needs to be modified to use the newforms. I do not have much idea about the admin templates, so can't do that.
# Method password_reset gives, me a (10061, 'Connection refused') error, but that is coz I am on a winodws machine, with no smtp server.

Attachments (1)

auth.diff (20.2 KB) - added by Shabda <shabda.raaj@…> 7 years ago.
Patch modifying contrib/auth/views.py and contrib/auth/forms.py

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Shabda <shabda.raaj@…>

Patch modifying contrib/auth/views.py and contrib/auth/forms.py

comment:1 Changed 7 years ago by Shabda <shabda.raaj@…>

  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to shabda
  • Patch needs improvement unset

comment:2 Changed 7 years ago by brosner

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6083.

Note: See TracTickets for help on using tickets.
Back to Top