Opened 8 years ago

Closed 8 years ago

#6140 closed (duplicate)

Test runner does not test apps that do not have model files

Reported by: Moof Owned by: nobody
Component: Testing framework Version: master
Severity: Keywords: test middleware
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


The last three applications I've created are either middleware or do no database work. I'd like their tests to be included in a standard test, and I see no reason to clutter my application with an empty file.

The test runner should be modified to search for a tests module in any of the defined installed_apps. Otherwise debugging can get a bit difficult if you can't be certain your middleware, etc, is not the reason your tests are failing.

Change History (3)

comment:1 Changed 8 years ago by Eratosfen

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I confirm this. Installed applications without are not tested at all by test runner

comment:2 Changed 8 years ago by Simon G <dev@…>

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 8 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3310.

Note: See TracTickets for help on using tickets.
Back to Top