Opened 8 years ago

Closed 7 years ago

#6102 closed (wontfix)

setup_environ() should preserve DJANGO_SETTINGS_MODULE as-is

Reported by: erob Owned by: erob
Component: Core (Other) Version: master
Severity: Keywords: setup_environ, call_command, management
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Attached is a patch for setup_environ(). This method should allow users to
use a arbitrary settings module/package from sys.path, thus preserving the ability
to overrides any app-specific settings.

Attachments (1)

setup_environ.diff (781 bytes) - added by erob 8 years ago.
initial revision

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by erob

initial revision

comment:1 Changed 8 years ago by erob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Status changed from new to assigned

comment:2 Changed 8 years ago by Simon G <dev@…>

  • Triage Stage changed from Unreviewed to Ready for checkin

comment:3 Changed 7 years ago by mtredinnick

  • Resolution set to wontfix
  • Status changed from assigned to closed

No, I think this would be a bit of a dangerous change, since it would leave the environment variable and the settings in use out of synchronisation and that will lead to difficult to reproduce bugs. If your code uses the environment variable, you should make sure to call setup_environ() with the value of the environment variable.

Note: See TracTickets for help on using tickets.
Back to Top