Opened 8 years ago

Closed 8 years ago

#6082 closed (fixed)

File based Session test fails for lack of /tmp directory on Windows Based System

Reported by: jags78 Owned by: jags78
Component: contrib.sessions Version: master
Severity: Keywords: test session file
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When running the built in tests on a Windows based system you will get a consistent failure in the file store session test because the default /tmp directory is more than likely missing. A quick solution to the problem is to set SESSION_FILE_PATH to a directory that exists on your system. This should be modified to use the environments temp directory.

Attachments (1)

6082.diff (1.6 KB) - added by jags78 8 years ago.
Patch for missing directory

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by jags78

Patch for missing directory

comment:1 Changed 8 years ago by jags78

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 8 years ago by jags78

  • Owner changed from nobody to jags78

comment:3 Changed 8 years ago by Simon G <dev@…>

  • Triage Stage changed from Unreviewed to Ready for checkin

comment:4 Changed 8 years ago by jacob

  • Resolution set to fixed
  • Status changed from new to closed

(In [6889]) Fixed #6082: file-based sessions now verify that SESSION_FILE_PATH is a valid storage location, and raise ImproperlyConfigured if not. Thanks, jags78.

Note: See TracTickets for help on using tickets.
Back to Top