Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6038 closed (fixed)

syncdb: reraise ImportError in app.management.py

Reported by: Thomas Güttler <hv@…> Owned by: nobody
Component: Core (Management commands) Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Up to now ImportErrors in app.management.py are ignored. This
small patch reraises the ImportError, if it was caused by an existing management.py.

If app.management.py does not exist, it ignores the ImportError.

Attachments (1)

syncdb_reraise_import_error.diff (621 bytes) - added by Thomas Güttler <hv@…> 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Thomas Güttler <hv@…>

comment:1 Changed 7 years ago by mcroydon

  • Component changed from Uncategorized to django-admin.py
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 7 years ago by Simon G <dev@…>

  • Triage Stage changed from Unreviewed to Ready for checkin

comment:3 Changed 7 years ago by mtredinnick

This has the standard problem of being very fragile because it relies on the human-readable string for computer processing. I'm going to check it in, since it adds utility, but if it causes problems on, say, Jython, by causing spurious exceptions to be raised, we should back it out immediately.

comment:4 Changed 7 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [6829]) Fixed #6038 -- Don't hide some types of errors in syncdb. Thanks, Thomas Güttler.

comment:5 Changed 7 years ago by Thomas Güttler <hv@…>

  • Cc hv@… removed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.