Code

Opened 6 years ago

Closed 6 years ago

#5994 closed (duplicate)

{% url %} doesn't support patterns with literal dots

Reported by: adamv Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

URL patterns with literal dots can't be generated via the {% url %} tag. I don't have a fix, but I've added a test which demonstrates the problem.

Attachments (1)

test-url-tag-fails-on-dots.patch (1.7 KB) - added by adamv 6 years ago.
Test to demonstrate the problem.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by adamv

Test to demonstrate the problem.

comment:1 Changed 6 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2977. I currently have an improved patch in the works for that ticket, so it'll be fixed soon.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.