Opened 16 years ago

Closed 4 months ago

Last modified 4 months ago

#5929 closed New feature (duplicate)

Allow Fields to use multiple db columns (complex datatypes)

Reported by: Daniel Poelzleithner Owned by: HAMA Barhamou
Component: Database layer (models, ORM) Version: dev
Severity: Normal Keywords:
Cc: Pavel Anossov, artagnon, Daniel Barreto, James Turk, glassreistor, ben.coughlan@…, ognajd@…, j.arnds@…, carlos.palol@…, cmawebsite@…, Frank Sachsenheim Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Currently it seems that it is not possible to have complex db filds. For example:
Implementation of a IP model which actually should be a field type not a model. The implementation is not clean, because foreign key lookups for example do not work. The model maps for example:

NetworkAddress.objects.filter(ip__in="192.168.0.10/16")

into a complex query for a ip resisting in a network range.

Due the fact that model fields can only map to one db column, many complex data types can't be implemented. For example a ipv6 ip address which is a 128 bit value can't be handled by most db implementations of integer fields, so it has to be expanded to multiple columns plus a additional netmask column. Using varchar doesn't work because there is no way to search for network ranges or IPs in ranges, etc...
I think a field should be able to implement lookup mappings which can be overridden to implement complex datatypes as well as use multiple db fields.

Change History (32)

comment:1 by Jim Meier <jim-django@…>, 16 years ago

The relational db literature seems to teach me that related tables (and so related models) would seem to already be the standard way to handle complex data types. Why do you say that this IP model should be a field type rather than a model?

comment:2 by Daniel Poelzleithner, 16 years ago

Triage Stage: UnreviewedDesign decision needed

Let's see another example:
http://django-coordinatesfield.googlecode.com/svn/trunk/field.py

This Field is implemented as a Charfield which is actually not the right datatype. The right datatype would be 2 or 3 float or decimal values or a real geos point value.

First thing: I'm not sure if it is currently possible to fix the IP Model, but currently the lookups only work if you filter trough the NetworkAddress model itself, because it uses a special manager to rewrite the simplified lookup methods into real ones. Becaus this is manager specific, there is no way to make lookups through the normal ForeignKey interface. So every lookups is specific for this model. Not good.

The NetworkAddress Model is quite complex, because it implements some other required tools. But actually, the system uses ForeignKey relations to this model that really only represents a simple IP without all the blow, but blowing this table into a really hugh one. This is another point: performance. If you have some models with only a view records that has to be fast, and some with really many entries, lets say millions and you have lookups to the ip field queries are much slower than real implementations.

For me this is a point of clarity. A field implements a type of data, which will be implemented in one way or the other depending on the database backend used. Thats the sense of having a abstraction layer, and if most or non of the databases don't have a type that fits, it's still one field for me, even when the implementation of field uses more then one db field to implement a the functionality as it should. A model represents for me a more or less independent peace of informations that could be referred to, but is not essentially coupled to. It's just, that i don't feel like that it's right designed right in such cases :-)

comment:3 by Malcolm Tredinnick, 16 years ago

Keywords: qs-rf removed

Removing the qs-rf keyword, since this is out of scope for the SQL construction rewrite. It's something we can look at after that is completed, though.

comment:4 by Jacob, 16 years ago

Version: other branchSVN

comment:5 by Jacob, 16 years ago

Triage Stage: Design decision neededAccepted

comment:6 by Gonzalo Saavedra, 16 years ago

Cc: Gonzalo Saavedra added
Owner: changed from nobody to Gonzalo Saavedra
Status: newassigned

comment:7 by Gonzalo Saavedra, 16 years ago

Owner: Gonzalo Saavedra removed
Status: assignednew

Oops, sorry. Didn't mean to assign this ticket, just wanted to add myself to the Cc list.

comment:8 by Pavel Anossov, 15 years ago

Cc: Pavel Anossov added

comment:9 by artagnon, 15 years ago

Cc: artagnon added

comment:10 by Daniel Barreto, 15 years ago

Cc: Daniel Barreto added

comment:11 by James Turk, 15 years ago

Cc: James Turk added

comment:12 by Piotr Czachur, 14 years ago

Guys,
any chance it will be implemented in reasonable time?
I'm sure many users are looking forward it.

comment:13 by None, 14 years ago

Cc: glassreistor added

Anyone working on this?

comment:14 by jdrago, 14 years ago

coderanger convinced me to offer this up on github:

http://gist.github.com/476058

This appears to interact nicely with both the admin interface and South, but I defer to others on how to make this prettier.

comment:15 by jdrago, 14 years ago

Also, my inspiration/base code for that github posting was from dcramer's ratings system:

http://github.com/dcramer/django-ratings

So if there's anything particularly clever in my gist, it is probably his idea.

comment:16 by Gabriel Hurley, 13 years ago

Severity: Normal
Type: New feature

comment:17 by ben.coughlan@…, 13 years ago

Cc: ben.coughlan@… added
Easy pickings: unset

This would 'really' simplify django support for python-money. I'd like to have a MoneyField which needs two columns, one for a Decimal value and another for a 3 character currency code.

Right now we're using the example found here but it leaves a lot to be desired regarding lookups and aggregates.

comment:18 by Aymeric Augustin, 12 years ago

UI/UX: unset

Change UI/UX from NULL to False.

comment:19 by anonymous, 12 years ago

Any update? I need pseudo-tz-aware field for date time, as anything but PostgreSQL supports timezone aware. I plan to use one column for date time and another for timezone name.

comment:21 by Gonzalo Saavedra, 12 years ago

Cc: Gonzalo Saavedra removed

comment:22 by Daniel Sokolowski, 11 years ago

Cc: ognajd@… added

comment:23 by Jelko Arnds, 11 years ago

Cc: j.arnds@… added

comment:24 by Carlos Palol, 11 years ago

Cc: carlos.palol@… added

comment:25 by Collin Anderson, 9 years ago

Cc: cmawebsite@… added

This should be much easier now that the _meta refactor is complete.

comment:27 by Frank Sachsenheim, 5 years ago

Cc: Frank Sachsenheim added

comment:28 by HAMA Barhamou, 16 months ago

Hi, I would like to work on this topic. Is it still relevant or not?

Last edited 16 months ago by HAMA Barhamou (previous) (diff)

comment:29 by HAMA Barhamou, 16 months ago

Owner: set to HAMA Barhamou
Status: newassigned

comment:30 by Randy Giffen, 15 months ago

Another example is a Blood Pressure field composed of 2 values that should be stored in separate db columns.

comment:31 by Kound, 8 months ago

This is also needed if you want to support a user entering a value in different units.
Required for this this plugin .

comment:32 by Mariusz Felisiak, 4 months ago

Resolution: duplicate
Status: assignedclosed

Duplicate of #373.

comment:33 by HAMA Barhamou, 4 months ago

Dear Members of Tickets #5929 and #373, I invite you to join a new discussion to clarify the differences and overlaps between these two tickets and address why #373 was marked as a duplicate

https://forum.djangoproject.com/t/request-for-clarification-and-guidance-on-the-status-of-ticket-5929-following-closure-of-ticket-373/26075

Note: See TracTickets for help on using tickets.
Back to Top