Opened 8 years ago

Closed 8 years ago

#5927 closed (duplicate)

form cleaned_data does not have uploaded request.FILES content

Reported by: stefan@… Owned by: nobody
Component: *.djangoproject.com Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi,

I've file uploading in my project for a while now and it worked pretty fine.
But after not testing it for a while it seems that since a more or less recent django svn version
things stopped working. My code is like this:

        print request.FILES
        # files have <content omitted> printed

        request.POST.update(request.FILES)
        print request.POST
        # same as above, content is there

        form = TestForm(request.POST)

        if form.is_valid():
           # form.cleaned_data does not contain content anymore

I've tried some things and I can only think of a bug in django.

Change History (1)

comment:1 Changed 8 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5928

Note: See TracTickets for help on using tickets.
Back to Top