Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5864 closed (invalid)

min_length CharField does not check against required=False in cleaned_data()

Reported by: tesseracter@… Owned by: nobody
Component: Forms Version: master
Severity: Keywords: min_length, required, cleaned_data
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

with a formfield "myfield = CharField( min_length=6, max_length=75, required=False)"
when accessing the form.cleaned_data(), raises an exception, and removing min_length=6 stops the exception from happening.

Change History (2)

comment:1 Changed 7 years ago by brosner

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

This appears to fixed since it was reported. It was confirmed by the submitter in IRC.

comment:2 Changed 7 years ago by brosner

Re-open with more information and a test case if it is a problem.

Note: See TracTickets for help on using tickets.
Back to Top