Code

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#586 closed defect (fixed)

raw_id_admin should work with non-integer primary keys

Reported by: adrian Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

raw_id_admin doesn't work with non-integer primary keys, but it should. See http://groups.google.com/group/django-users/browse_thread/thread/07cb1bda25cbbec2/1bee9ed15652f843

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by adrian

  • Status changed from new to assigned

comment:2 Changed 9 years ago by adrian

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [785]) Fixed #586 -- raw_id_admin now works with non-integer primary keys

comment:3 Changed 9 years ago by slashzero

Now integer pk's are broken

comment:4 Changed 9 years ago by adrian

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm on it.

comment:5 Changed 9 years ago by adrian

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [800]) Fixed #586 -- Fixed bug in raw_id_admin caused by [785]. Thanks for the heads-up, slashzero

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.