Code

Opened 6 years ago

Closed 6 years ago

#5859 closed (duplicate)

Redirect middleware should use iexact to match old_path

Reported by: E Miller <thnntn+djtrac@…> Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: redirects
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This, or drop unique_together=(('site', 'old_path'),) in Redirect model.

The problem is that you can't add both '/About.html' and '/about.html' as two redirects for the same site.

Attachments (1)

contrib_redirect_middleware.diff (1006 bytes) - added by E Miller <thnntn+djtrac@…> 6 years ago.
redirect middleware w/iexact

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by E Miller <thnntn+djtrac@…>

redirect middleware w/iexact

comment:1 Changed 6 years ago by Simon G <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 6 years ago by lukeplant

Alternatively, fix #4562

comment:3 Changed 6 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Yeah, this is a duplicate of #4562.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.