Code

Opened 7 years ago

Closed 7 years ago

#5774 closed (wontfix)

Default '----------' option in choices dropdowns present even when blank=False

Reported by: jim-django@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the admin (not newforms-admin) and therefor, in old forms, fields with choices set get dropdowns whose first item is "--------" indicating "not selected".
This appears even when the field has blank=True, and it is always an error to select the "---------" option.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

That's by design, so that the first option isn't just implicitly selected. Even if this was to change, it's not going to change in old-admin.

If you want to discuss this then I suggest bringing it up in the django-dev Google group.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.