Opened 8 years ago

Closed 8 years ago

#5717 closed (wontfix)

Suggestion: support for apps default settings

Reported by: Guilherme M. Gondim (semente) <semente@…> Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Is great for 3rd party apps if Django import default settings from a app like myproject.myapp.settings or myproject.myapp.app_settings.

Change History (1)

comment:1 Changed 8 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

We've decided in the past not to do this. The problem is that it is order dependent (the order the settings are processed depends on other apps) and there are some chicken-and-egg problems when importing apps as part of importing settings. Instead we only load applications after the settings file has been fully imported.

So applications should tell the use what settings they need to create (which could be as simple as asking them to import a file from the settings).

Note: See TracTickets for help on using tickets.
Back to Top