Code

Opened 7 years ago

Closed 7 years ago

#5650 closed (duplicate)

'Save and add another' is displayed even without add permission

Reported by: Silviu Julean <sjulean@…> Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords: newforms admin add permission
Cc: dany@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Even if a user does not have add permission for a certain model, the 'Save and add another' button (or 'Save as', according to the model admin save_as option) is displayed.

The expected behavior is to hide that button when the user doesn't have the add permission.

I have attached a (trivial) patch against newforms-admin r6442.

Attachments (2)

skip_save_as_without_perm_r6442.patch (1.7 KB) - added by Silviu Julean <sjulean@…> 7 years ago.
Initial patch against newforms-admin r6442
skip_save_as_without_perm_r6442.2.patch (1.8 KB) - added by Silviu Julean <sjulean@…> 7 years ago.
New patch that doesn't crash on add

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Silviu Julean <sjulean@…>

Initial patch against newforms-admin r6442

comment:1 Changed 7 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3817.

Changed 7 years ago by Silviu Julean <sjulean@…>

New patch that doesn't crash on add

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.