Code

Opened 7 years ago

Closed 7 years ago

#5583 closed (duplicate)

admin crashes on edit form pages since r6342

Reported by: sjulean@… Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords: newforms-admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Only r6327 of the newforms-admin is usable for me right now. Since r6342, attempting to edit an object results in the following error:

Traceback (most recent call last):
File "/home/sjulean/projects/django/django/core/handlers/base.py" in _real_get_response
  81. response = callback(request, *callback_args, **callback_kwargs)
File "/home/sjulean/projects/django/django/contrib/admin/sites.py" in root
  136. return self.model_page(request, *url.split('/', 2))
File "/home/sjulean/projects/django/django/contrib/admin/sites.py" in model_page
  153. return admin_obj(request, rest_of_url)
File "/home/sjulean/projects/django/django/contrib/admin/options.py" in __call__
  245. return self.add_view(request)
File "/home/sjulean/projects/django/django/contrib/admin/options.py" in add_view
  474. form = ModelForm(initial=request.GET)
File "/home/sjulean/projects/django/django/newforms/forms.py" in __init__
  81. self.fields = self.base_fields.copy()
File "/home/sjulean/projects/django/django/newforms/forms.py" in copy
  34. return SortedDictFromList([(k, copy.deepcopy(v)) for k, v in self.items()])
File "/home/sjulean/projects/django/django/newforms/fields.py" in __deepcopy__
  107. result.widget = copy.deepcopy(self.widget, memo)

  TypeError at /admin/auth/user/add/
  instancemethod expected at least 2 arguments, got 0

I can always reproduce this error by simply starting a new project, enabling the admin interface from settings and urls, doing a syncdb, and opening /admin/auth/user/add/.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5505.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.