Opened 8 years ago

Closed 2 years ago

Last modified 18 months ago

#5579 closed Bug (fixed)

Trac activation mail is sent from 'webmaster@localhost'

Reported by: tback Owned by: anonymous
Component: *.djangoproject.com Version:
Severity: Normal Keywords: activation email trac
Cc: mariovahos@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by mboersma)

The activation email that is sent after registration is sent from 'webmaster@localhost' which encourages some spamfilters to treat the message as spam.

Change History (23)

comment:1 follow-up: Changed 8 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 8 years ago by mir

  • Resolution set to invalid
  • Status changed from new to closed

This looks as if you were simply not aware of the settings posted above.

comment:3 Changed 8 years ago by mboersma

  • Description modified (diff)
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from activation mail is sent from 'webmaster@localhost' to Trac activation mail is sent from 'webmaster@localhost'
  • Triage Stage changed from Unreviewed to Accepted

I think he's referring to the Django website itself, which apparently has not allowed anyone to sign up since last week's move. See here:
http://www.djangoproject.com/accounts/register/

I'm not sure if the problem is that Trac sends the account confirmation email from "webmaster@localhost," which is then eaten by spam filters, or what. But I've tried four times since Sunday to create a new account, using two different email addresses, and I have not received the confirm email for any of them.

comment:4 Changed 8 years ago by petrilli

Just as a bit of debugging information, from a sign-up today:

Delivered-To: XXX@amber.org
Received: by 10.66.238.5 with SMTP id l5cs50168ugh;
        Tue, 25 Sep 2007 11:31:08 -0700 (PDT)
Received: by 10.115.77.1 with SMTP id e1mr311878wal.1190745066840;
        Tue, 25 Sep 2007 11:31:06 -0700 (PDT)
Return-Path: <webmaster@localhost>
Received: from django.com ([64.207.133.30])
        by mx.google.com with ESMTP id g1si13062793rvb.2007.09.25.11.31.05;
        Tue, 25 Sep 2007 11:31:06 -0700 (PDT)
Received-SPF: neutral (google.com: 64.207.133.30 is neither permitted nor denied by best guess record for domain of webmaster@localhost) client-ip=64.207.133.30;
Authentication-Results: mx.google.com; spf=neutral (google.com: 64.207.133.30 is neither permitted nor denied by best guess record for domain of webmaster@localhost) smtp.mail=webmaster@localhost
Received: from django.com (localhost [127.0.0.1])
	by django.com (Postfix) with ESMTP id 93E9F44C162
	for <petrilli@amber.org>; Tue, 25 Sep 2007 11:31:05 -0700 (PDT)
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable
Subject: Activate your new account at www.djangoproject.com
From: webmaster@localhost
To: XXX@amber.org
Date: Tue, 25 Sep 2007 18:31:05 -0000
Message-ID: <20070925183105.14128.31131@django.com>


Someone, hopefully you, signed up for a new account at http://www.djangopro=
ject.com/ using this email address. If it was you, and you'd like to activa=
te and use your account, click the link below or copy and paste it into you=
r web browser's address bar:

http://www.djangoproject.com/accounts/activate/XXX

If you didn't request this, you don't need to do anything; you won't receiv=
e any more email from us, and the account will expire automatically in thre=
e days.

comment:5 follow-up: Changed 8 years ago by mboersma

  • Resolution set to fixed
  • Status changed from reopened to closed

Jacob changed the sender to "noreply@…" and it seems to be working now.

comment:6 in reply to: ↑ 5 Changed 7 years ago by anonymous

Replying to mboersma:

Jacob changed the sender to "noreply@…" and it seems to be working now.

comment:7 Changed 4 years ago by anonymous

  • Easy pickings unset
  • Resolution fixed deleted
  • Severity set to Normal
  • Status changed from closed to reopened
  • Type set to Uncategorized

comment:8 Changed 4 years ago by anonymous

  • Owner changed from nobody to anonymous
  • Status changed from reopened to new

comment:9 Changed 4 years ago by jezdez

  • Resolution set to needsinfo
  • Status changed from new to closed

I wasn't able to reproduce the issue.

comment:10 Changed 4 years ago by fclail@…

  • UI/UX unset

Seen this contact site listed on the Gary Clail website, and was wondering if I could get 'follow up' comments I made in 2002 deleted? Thanksin advance? Frances C.

comment:11 Changed 4 years ago by anonymous

  • Easy pickings set
  • Has patch set
  • Needs documentation set
  • Patch needs improvement set

comment:12 Changed 4 years ago by anonymous

  • Component changed from Djangoproject.com Web site to Database layer (models, ORM)
  • Resolution needsinfo deleted
  • Status changed from closed to reopened
  • Version set to 1.2-alpha

comment:13 Changed 4 years ago by PaulM

  • Component changed from Database layer (models, ORM) to Djangoproject.com Web site
  • Easy pickings unset
  • Has patch unset
  • Needs documentation unset
  • Patch needs improvement unset
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Type changed from Uncategorized to Bug
  • Version 1.2-alpha deleted

Closing again. Not sure why this post seems to attract bots. Wish trac had a way to lock issues.

comment:14 Changed 3 years ago by alexizurieta@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:15 Changed 3 years ago by aaugustin

  • Resolution set to fixed
  • Status changed from reopened to closed

Please don't reopen ticket without providing any explanations.

comment:16 Changed 3 years ago by mariovahos@…

  • Cc mariovahos@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:17 Changed 3 years ago by claudep

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:18 Changed 3 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:19 Changed 3 years ago by aaugustin

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:20 Changed 2 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to new

comment:21 Changed 2 years ago by anonymous

Unable to open my seaside hideaway

comment:22 Changed 2 years ago by timo

  • Resolution set to fixed
  • Status changed from new to closed

comment:23 in reply to: ↑ 1 Changed 18 months ago by frammie@…

Note: See TracTickets for help on using tickets.
Back to Top