Opened 8 years ago

Closed 8 years ago

#5576 closed (duplicate)

Django from subdirectorys with FCGI

Reported by: wintesa@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When running Django from a subdirectory in a shared webhosting enviroment on trying to use the admin, it redirects one back to the root of the webhost cutting out the directory that it originated from.

ps I didnt check if frank.com actually exists.


The .htaccess in /myproject:

AddHandler fastcgi-script .fcgi
RewriteEngine On
RewriteRule ^(media/.*)$ - [L]
RewriteCond %{REQUEST_FILENAME} !(django.fcgi)
RewriteRule ^(.*)$ /~eric/myproject/django.fcgi/myproject/$1 [QSA,L]

urls.py for myproject:

(r'^myproject/admin/', include('django.contrib.admin.urls')),


Admin Page (works):
http://www.frank.com/~eric/myproject/admin

On login or failure (error):
http://www.frank.com/myproject/admin
Get redirected back to the root of the webhosting.

This guide was followed mostly to implement the shared hosting solution;
http://wiki.asmallorange.com/HOWTODjangoFastCGI?show_comments=1#comments
and this;
http://groups.google.com/group/django-users/browse_thread/thread/1b740572c9c102eb/ff867303ea85e6ec?lnk=gst&q=admin+nextether&rnum=1#ff867303ea85e6ec

Change History (1)

comment:1 Changed 8 years ago by brosner

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #285.

Note: See TracTickets for help on using tickets.
Back to Top