Opened 8 years ago

Closed 8 years ago

#5569 closed (duplicate)

BUG: "python manage.py syncdb" while running tutorial crashes

Reported by: eshapira@… Owned by: nobody
Component: Core (Management commands) Version: master
Severity: Keywords: syncdb
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Python Version: 2.5, OS: Windows XP
I was trying out the tutorial with the SVN version.
While running "python manage.py syncdb" I get a traceback in call_command() in django.core.management.init.py


Tracback:

D:\projects\django_tutorial\src\mysite>python manage.py syncdb
Traceback (most recent call last):

File "manage.py", line 11, in <module>

execute_manager(settings)

File "D:\Python25\Lib\site-packages\django\core\management\init.py", line 264, in execute_mana

ger

utility.execute()

File "D:\Python25\Lib\site-packages\django\core\management\init.py", line 215, in execute

self.fetch_command(subcommand).run_from_argv(self.argv)

File "D:\Python25\lib\site-packages\django\core\management\base.py", line 70, in run_from_argv

self.execute(*args, options.dict)

File "D:\Python25\lib\site-packages\django\core\management\base.py", line 84, in execute

output = self.handle(*args, options)

File "D:\Python25\lib\site-packages\django\core\management\base.py", line 168, in handle

return self.handle_noargs(options)

File "d:\python25\lib\site-packages\django\core\management\commands\syncdb.py", line 137, in handl

e_noargs

call_command('loaddata', subcommand='initial_data', verbosity=verbosity)

File "D:\Python25\Lib\site-packages\django\core\management\init.py", line 120, in call_command

klass = load_command_class(app_name, subcommand)

NameError: global name 'subcommand' is not defined

Change History (3)

comment:1 Changed 8 years ago by mir

  • Component changed from Core framework to django-admin.py
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Yeah, changeset [6402] contains a typo.

comment:2 Changed 8 years ago by mir

  • Triage Stage changed from Accepted to Ready for checkin

Please accept this as a patch:

django\core\management\__init.py__, line 120: s/subcommand/name/

(I currently don't have access to a clean django code base and can't create a patch)

comment:3 Changed 8 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

dupe of #5566

Note: See TracTickets for help on using tickets.
Back to Top