Opened 8 years ago

Closed 8 years ago

#5530 closed (duplicate)

ImportError: No module named mysql.base

Reported by: anonymous Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Keywords: mysql
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I got this error:

Traceback (most recent call last):
  File "low_level_test1.cgi", line 84, in ?
    from django.test.utils import setup_test_environment
  File "./django/test/", line 6, in ?
    from django.test.testcases import TestCase
  File "./django/test/", line 6, in ?
    from django.db import transaction
  File "./django/db/", line 23, in ?
    backend = __import__('%s.base' % settings.DATABASE_ENGINE, {}, {}, [''])
ImportError: No module named mysql.base

But this is not the true error. The real problem is the version checking routines here:
Is raises a ImportError, too!

So i don't see message "MySQLdb-1.2.1p2 or newer is required; you have..." i see the wrong error messages from above: "No module named mysql.base"

Solution: I think the Version Exception must be a different class and not the generetic ImportError.

Change History (1)

comment:1 Changed 8 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5531

Note: See TracTickets for help on using tickets.
Back to Top