Opened 8 years ago

Closed 8 years ago

#5512 closed (fixed)

DB docs should mention the ImmutableSet issue for MySQLdb

Reported by: peter@… Owned by: mboersma
Component: Documentation Version: master
Severity: Keywords: MySQLdb
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

New to Django I found that I needed an updated version of MySQLdb. As I am on Windows (for learning
Django) messing with MySQLdb is a bit fraught because the author does not actually support
Windows. I found that python manage.py syncdb failed with the error ImportError: cannot import name ImmutableSet

The fix for this is at http://code.djangoproject.com/wiki/InstallationPitfalls (remove sets.py from MySQLdb folder) but
it took me a long time to find it. I wondered about PYTHONPATH (which I normally never use), about my Python 2.4.4 not
being upt to date enough for the MySQLdb. So I would suggest that a link to the issue is included in the
paragraph MySQLdb on the page http://www.djangoproject.com/documentation/databases/.

Attachments (1)

5512.diff (907 bytes) - added by mboersma 8 years ago.
Documents the "ImmutableSet not found" gotcha for MySQLdb

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by mboersma

Documents the "ImmutableSet not found" gotcha for MySQLdb

comment:1 Changed 8 years ago by mboersma

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to mboersma
  • Patch needs improvement unset
  • Status changed from new to assigned
  • Summary changed from Reference the ImmutableSet issue for MySQLdb to DB docs should mention the ImmutableSet issue for MySQLdb
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:2 Changed 8 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6561]) Fixed #5512 -- Added a note about a common MySQLdb upgrade problem. Thanks,
Matt Boersma.

Note: See TracTickets for help on using tickets.
Back to Top