Opened 8 years ago

Closed 8 years ago

#5491 closed (fixed)

Make sort filenames when processing files

Reported by: ramiro Owned by: nobody
Component: Internationalization Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


When enumerates the files it will extract translatable strings from, filesystem enumeration peculiarities cause changes in the layout of th final .po file being created/updated. In the case of the Django translations this difficult reviewing and makes translator-submitted patches bigger than should be.

The patch just makes it .sort() the list of files to process before.

Attachments (1)

make_mess_file_sort.diff (854 bytes) - added by ramiro 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by ramiro

comment:1 Changed 8 years ago by Simon G. <dev@…>

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:2 Changed 8 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [6445]) Fixed #5491 -- Changed PO file generation to sort the filenames we scan prior
to passing them to gettext. This should help reduce the changes in line
orderings caused by different translators using different operating systems and
locales. Based on a patch from Ramiro Morales.

Note: See TracTickets for help on using tickets.
Back to Top