Opened 8 years ago

Closed 8 years ago

#5276 closed (duplicate)

change filenames of uploaded files

Reported by: George Karpenkov <admin@…> Owned by: adrian
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Right now when two files with identical name are uploaded, one of them will get '_' prefix.
I consider this solution quite ugly and impractical, because there are some situations when many files with same name will be uploaded. And when filename reaches critical length, problems will come up.
Consider online gallery, for example - how many users might wish to upload the picture called 'cat.jpg'?
I think the people from have created a good solution for that problem - hash from some value (number of files?) is added to the filename, and they get filenames like 'catfg3.jpg'
I believe that same thing should be implemented in Django.

Change History (1)

comment:1 Changed 8 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5029, and see also the wiki page CustomUploadAndFilters

Note: See TracTickets for help on using tickets.
Back to Top