Code

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#5217 closed (duplicate)

Settings are unable to be imported if project name is the same as the parent directory

Reported by: spe.stani.be@… Owned by: jacob
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

"From the command line, cd into a directory where you’d like to store your code, then run the command django-admin.py startproject mysite. This will create a mysite directory in your current directory." This will not work when the the project name is the same as the parent directory. (Eg. in the folder mysite, you can't start mysite.) Django will fail to import the settings.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from tutorial remark to Settings are unable to be imported if project name is the same as the parent directory

Duplicate of #4850

comment:2 Changed 3 years ago by techtonik

Wrong duplicate, the problem is in #1908 and it is repeatable with Django 1.1.2 and Python 2.7

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.