Opened 16 years ago

Closed 16 years ago

#5075 closed (duplicate)

Oracle and Unicode Errors

Reported by: Thejaswi Puthraya Owned by: Adrian Holovaty
Component: Database layer (models, ORM) Version: dev
Severity: Keywords: oracle, unicode
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


On Django SVN 5788 and cx_Oracle 4.1.3.
Looks like Oracle backend is still not unicode compatible.
When the below is tried:

python sql <app_name>


python syncdb

the output is:

Traceback (most recent call last):
  File "", line 11, in <module>
  File "/usr/lib/python2.5/site-packages/django/core/", line 1745, in execute_manager
    execute_from_command_line(action_mapping, argv)
  File "/usr/lib/python2.5/site-packages/django/core/", line 1704, in execute_from_command_line
    output = action_mapping[action](mod)
  File "/usr/lib/python2.5/site-packages/django/core/", line 117, in get_sql_create
    known_models = set([model for model in _get_installed_models(_get_table_list()) if model not in app_models])
  File "/usr/lib/python2.5/site-packages/django/core/", line 71, in _get_installed_models
    return set([m for m in all_models if converter(m._meta.db_table) in map(converter, table_list)])
TypeError: descriptor 'upper' requires a 'str' object but received a 'unicode'

Change History (1)

comment:1 Changed 16 years ago by ian.g.kelly@…

Resolution: duplicate
Status: newclosed

Already reported as #4827.

Note: See TracTickets for help on using tickets.
Back to Top