Opened 8 years ago

Closed 8 years ago

#5008 closed (duplicate)

in mysql backend the test for MySQLdb version fail

Reported by: p.patruno@… Owned by: adrian
Component: Database layer (models, ORM) Version: master
Severity: Keywords: MySQL database backend Database.version_info MySQLdb
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


On my platform:

import MySQLdb as Database

(1, 2, 2, 'final', 0)

so the test in

version = Database.version_info
if (version < (1,2,1) or (version[:3] == (1, 2, 1) and

(len(version) < 5 or version[3] != 'final' or version[4] < 2))):

raise ImportError, "MySQLdb-1.2.1p2 or newer is required; you have %s" % Database.version

fail and raise an error, but I think the version of MySQLdb is right

Paolo Patruno

Change History (1)

comment:1 Changed 8 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Are you on Fedora? This looks to be a duplicate of #4743

Note: See TracTickets for help on using tickets.
Back to Top