Opened 8 years ago

Closed 8 years ago

#4920 closed (duplicate)

newforms-admin TabularInline with ManyToManyField breaks

Reported by: anonymous Owned by: adrian
Component: contrib.admin Version: master
Severity: Keywords: newforms-admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the newforms-admin, if a model has an inline (I've had issues with StackedInline and TabularInline) and the model used in the inline has a ManyToManyField the admin breaks returning:

Exception Value: 'StackedInline' object has no attribute 'filter_vertical'
Exception Location: /home/code/django/contrib/admin/options.py in formfield_for_dbfield, line 114

Exception Value: 'TabularInline' object has no attribute 'filter_vertical'
Exception Location: /home/code/django/contrib/admin/options.py in formfield_for_dbfield, line 114

It works fine if the ManyToManyField is commented out of the inline model temporarily.
The model with the ManyToManyField works fine in the admin on its own (not called as an edit inline).

Change History (1)

comment:1 Changed 8 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4761

Note: See TracTickets for help on using tickets.
Back to Top