Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4903 closed (duplicate)

views/debug.py: fallback to cgitb

Reported by: Thomas Güttler <hv@…> Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi,

Unicode errors in views/debug.py are hard to debug. You
don't see the buggy string, and you don't see the real
exception.

That's way I patched views/debug.py to fall back to cgitb
if rendering the technical 500 response failed.

Attachments (1)

debug_py_cgitb_fallback.diff (1.1 KB) - added by Thomas Güttler <hv@…> 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Thomas Güttler <hv@…>

comment:1 Changed 7 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4891.

comment:2 Changed 7 years ago by Thomas Güttler <hv@…>

Sorry this is not a duplicate.

This patch is about falling back to cgitb if there is an error in views/debug.py

#4891 is about errors at mod_python level (apache module).

Nevertheless I leave this closed, because since the unicode merge is stable,
I don't get errors in views/debug.py any more.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.