Code

Opened 7 years ago

Closed 7 years ago

#4859 closed (duplicate)

ImportError: MySQLdb-1.2.1p2 or newer is required; you have 1.2.2

Reported by: pat.j.anderson@… Owned by: jacob
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm using Fedora 7 with python2.5 and I track django-trunk regularly. I think this is a bug.

Below is my traceback:

Traceback (most recent call last):

File "manage.py", line 11, in <module>

execute_manager(settings)

File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1775, in execute_manager

execute_from_command_line(action_mapping, argv)

File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1662, in execute_from_command_line

action_mapping[action]()

File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1220, in validate

num_errors = get_validation_errors(outfile)

File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1014, in get_validation_errors

from django.db import models, connection

File "/usr/lib/python2.5/site-packages/django/db/init.py", line 11, in <module>

backend = import('django.db.backends.%s.base' % settings.DATABASE_ENGINE, {}, {}, [])

File "/usr/lib/python2.5/site-packages/django/db/backends/mysql/base.py", line 20, in <module>

raise ImportError, "MySQLdb-1.2.1p2 or newer is required; you have %s" % Database.version

ImportError: MySQLdb-1.2.1p2 or newer is required; you have 1.2.2

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Not a bug - unfortunately there are some fairly problematic bugs in MySQLdb less than 1.2.2p2 and Django needs the ..p2 version. You need to upgrade MySQLdb or change your database setting to mysql_old. There's more info here

comment:2 Changed 7 years ago by nick.lane.au@…

See: #4743

comment:3 Changed 7 years ago by Brian Rosner <brosner@…>

Wait, is it just me or is 1.2.2 a newer version than 1.2.1p2? The documentation says 1.2.1p2 or newer. It appears the submitter has 1.2.2. Just a quick thing I noticed.

comment:4 Changed 7 years ago by Simon G. <dev@…>

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Unreviewed to Accepted

Oh... oops. My bad! I misread that as 1.2.2p2 instead of 1.2.1p2

comment:5 Changed 7 years ago by Brian Rosner <brosner@…>

  • Resolution set to duplicate
  • Status changed from reopened to closed

While my observation may be correct, I should have looked at #4743. Marked as duplicate since submitter mentioned Fedora.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.