Code

Opened 7 years ago

Closed 7 years ago

#4784 closed (duplicate)

newforms-admin requires inner class Admin

Reported by: miracle2k <michael@…> Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The newforms-admin still requires a inner

class Admin:

pass

for each model that is used as a ForeignKey somewhere. If it is missing, the popup edit feature for those keys will not be available.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Honza Král <Honza.Kral@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This is solved with a patch in #4491
requiring inner Admin class is not nice, because it won't work for multiple admin sites.

comment:2 Changed 7 years ago by jkocherhans

  • Resolution set to duplicate
  • Status changed from new to closed

I'm pretty sure this is a duplicate of #4491 which was fixed in [6074].

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.