Code

Opened 7 years ago

Closed 7 years ago

#4777 closed (worksforme)

Documentation detail pages should have a link back to the doc index

Reported by: fishbolt@… Owned by: jacob
Component: *.djangoproject.com Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This document is very sketchy. In particular, it doesn't how to start django or where to go next. It mentions you can run django as a development HTTP server but it doesn't say how.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

I'm not sure which "document" you refer to. If you follow through the installation guide then the tutorial, you should be able to understand this.

Come back and post a ticket after that if you can offer a specific suggestion to improve the documentation.

comment:2 Changed 7 years ago by Charlie Reiman

You're right, I was unclear. I was speaking of this document

http://www.djangoproject.com/documentation/install

Which gets you to install it but doesn't actually say how to get anything running nor what the next step is. The problem is that you need to see it from the parent document (http://www.djangoproject.com/documentation/) where it makes sense. As a stand alone document, it just sort of ends with crap on my filesystem and nothing running and no direction where to go next.

It's not a big deal. I think I was just frustrated at the time.

comment:3 Changed 7 years ago by SmileyChris

  • Component changed from Documentation to Django Web site
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Document is incomplete to Documentation detail pages should have a link back to the doc index
  • Triage Stage changed from Unreviewed to Design decision needed

Thanks for the feedback, that's a lot more helpful.

You're right that it does make more sense when viewed from the parent document. The "installation" document handles just that.

I guess the "bug" here is that from a documentation page on the site, it isn't clear that you are actually just viewing one of a selection of available documentation pages.

comment:4 Changed 7 years ago by adrian

  • Resolution set to worksforme
  • Status changed from reopened to closed

The light green bar at the top of the page that says "Django documentation" links back to the docs.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.