Opened 8 years ago

Closed 8 years ago

#4757 closed (duplicate)

what db rights?

Reported by: Carl Karsten <carl@…> Owned by: jacob
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Needs something in there about db rightes.

carl@dell29:~/django/django-src/tests$ ./ --settings settings

Got an error creating the test database: (1044, "Access denied for user 'djangouser'@'%' to database 'django_test_db'")
It appears the test database, django_test_db, already exists. Type 'yes' to delete it, or 'no' to cancel: yes
Got an error recreating the test database: (1044, "Access denied for user 'djangouser'@'%' to database 'django_test_db'")
carl@dell29:~/django/django-src/tests$ mysql -u root
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 750
Server version: 5.0.38-Ubuntu_0ubuntu1-log Ubuntu 7.04 distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> show databases;
| Database |
| information_schema |
| RidgeMoorJonas |
| dj |
| djangodb |
| mysql |
5 rows in set (0.00 sec)


I am guessing the problem is:
DATABASE_USER = 'djangouser'
only has rites to
DATABASE_NAME = 'djangodb'

But the error message doesn't make that clear, and the docs don't say what is needed.

Change History (1)

comment:1 Changed 8 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report - I'm working on it. Duplicate of #4692.

Note: See TracTickets for help on using tickets.
Back to Top