Code

Opened 7 years ago

Closed 7 years ago

#4715 closed (duplicate)

syncdb attempt to create existing tables

Reported by: anonymous Owned by: jacob
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by mtredinnick)

Hi, I`have a problem, I run manage.py syndb first time all go well, but if I run another time (changing a model or no) I obtain the error

Creating table django_admin_log
Traceback (most recent call last):
  File "manage.py", line 11, in <module>
    execute_manager(settings)
  File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1736, in execute_manager
    execute_from_command_line(action_mapping, argv)
  File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1633, in execute_from_command_line
    action_mapping[action](int(options.verbosity), options.interactive)
  File "/usr/lib/python2.5/site-packages/django/core/management.py", line 572, in syncdb
    cursor.execute(statement)
  File "/usr/lib/python2.5/site-packages/django/db/backends/util.py", line 18, in execute
    return self.cursor.execute(sql, params)
psycopg2.ProgrammingError: la relación «django_admin_log» ya existe

in english: the relation <<django_admin_log>> exists.
Sorry, but my english is very bad

Tanks

Luis

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by mtredinnick

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

(Fixed description formatting)

I suspect you might be using some subversion code from a few days ago. This sounds like a problem we fixed earlier this week in the postgresql backend.

What code version are you using (if subversion trunk, please update to latest code and try again)? Which database backend?

comment:2 Changed 7 years ago by anonymous

Hi, yes the sersion is svn, I update it and the problem is solved, sorry for waste your time.
Luis

comment:3 Changed 7 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.