Opened 10 years ago

Closed 7 years ago

Last modified 4 years ago

#458 closed defect (wontfix)

"View on site" doesn't link to model's get_absoulte_url() method

Reported by: igor@… Owned by: adrian
Component: contrib.admin Version: 1.1-beta
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


"View on site" button doesn't link to model's get_absolute_url() method, but shows something like '/r/12/1/'. It could be observed on the generic Users model.

Change History (6)

comment:1 Changed 10 years ago by mattycakes@…

  • Resolution set to wontfix
  • Status changed from new to closed

This is not a bug, it's a redirect URL. Put in your main the line

    (r'^r/', include('django.conf.urls.shortcut')),

And as long as DEBUG is turned *off* in your settings.main you'll be redirected to the correct item.

comment:2 Changed 10 years ago by adrian

As of [620], the "/r" handler is automatically added to the admin URLconf whenever you do "django-admin startproject".

comment:3 Changed 10 years ago by Christopher Lenz <cmlenz@…>

This is no longer the case, is it? At least not on the magic-removal branch.

Why isn't this mapping [source:/django/branches/magic-removal/django/contrib/admin/ admin/] ?

comment:4 Changed 7 years ago by ankit

  • milestone set to 1.1
  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version set to 1.1-beta-1

it is not working.I have done debug=False also

comment:5 Changed 7 years ago by russellm

  • Resolution set to wontfix
  • Status changed from reopened to closed

If you are having difficulties, please ask on Django-users, rather than presumptively opening a 4 year old ticket.

comment:6 Changed 4 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Note: See TracTickets for help on using tickets.
Back to Top