Opened 9 years ago

Closed 6 weeks ago

#4548 closed Cleanup/optimization (fixed)

Add a username hint for password managers to admin's change_password form.

Reported by: Carl Karsten <carl@…> Owned by: adrian
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

http://192.168.1.22:8000/admin/auth/user/add/

username: x, password: y, confirm: z, hit Save.

get dialog: "Please confirm which user you are changing the password for" and a list of users, none of which are x.

hit cancel, get the expected error: "The two password fields didn't match."

Attachments (1)

Capture.PNG (45.6 KB) - added by fabiosantosart@… 4 years ago.
Screen capture of dialog.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

Working fine for me... maybe it was fixed somewhere along the way.

Changed 4 years ago by fabiosantosart@…

Screen capture of dialog.

comment:2 Changed 4 years ago by fabiosantosart@…

  • Easy pickings unset
  • Severity set to Normal
  • Type set to Uncategorized
  • UI/UX unset

I'm having the exact same problem on Firefox 14, Windows Server 2008 R2, Django 1.4 and the Django development server.

There is a small difference however. The dialog shows in another view, django.contrib.auth.views.password_change The list of users I get is also different. All users appear. I suppose Django is showing User.objects.all().

When the password you are changing from is the same as the password you are changing to, the dialog does not show up at all.

The dialog seems to be modal, and does not appear in Internet Explorer 9. I have tested no other browsers as of yet.

If the original reporter would show up and say whether he was using Windows Server and/or Firefox we could narrow down the bugs. In the meantime, I will try to reproduce it.

comment:3 Changed 4 years ago by carl@…

Carl here.

5 years later I think I understand, and I don't think this is a django problem at all.

The dialog is coming from the browser's "saved passwords" management system. There might be some meta tags that could be added to tell the browser something, but I don't think it is worth the trouble.

comment:4 Changed 7 weeks ago by sliverc

  • Resolution worksforme deleted
  • Status changed from closed to new

I have encountered this issue as well and found an easy fix.

See pull request https://github.com/django/django/pull/6745

comment:5 Changed 7 weeks ago by timgraham

  • Has patch set
  • Keywords password removed
  • Patch needs improvement set
  • Summary changed from create user, typo password, get "confirm pw change" dialog to Add a username hint for password managers to admin's change_password form.
  • Triage Stage changed from Unreviewed to Accepted
  • Type changed from Uncategorized to Cleanup/optimization

comment:6 Changed 6 weeks ago by timgraham

  • Patch needs improvement unset
  • Triage Stage changed from Accepted to Ready for checkin

comment:7 Changed 6 weeks ago by Tim Graham <timograham@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 5d8375fe:

Fixed #4548 -- Added username hint to admin's change_password form.

Note: See TracTickets for help on using tickets.
Back to Top