Code

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#4329 closed (invalid)

image generation by ReportLab

Reported by: Umesh Owned by: jacob
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

C:\djproject\trade\stock>mycharts.py > error.txt
Traceback (most recent call last):

File "C:\djproject\trade\stock\mycharts.py", line 116, in ?

c.save(formats=jpg?,outDir='temp',fnRoot='daychart')

File "C:\Python24\Lib\site-packages\reportlab\graphics\shapes.py", line 689, in save

renderPM.drawToFile(self, filename,fmt=bmFmt,showBoundary=getattr(self,'show

Border',rl_config.showBoundary),_extraKW(self,'_renderPM_',kw))

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 591,

in drawToFile

c = drawToPMCanvas(d, dpi=dpi, bg=bg, configPIL=configPIL, showBoundary=show

Boundary)

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 577,

in drawToPMCanvas

draw(d, c, 0, 0, showBoundary=showBoundary)

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 49,

in draw

R.draw(renderScaledDrawing(drawing), canvas, x, y, showBoundary=showBoundary

)

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderbase.py", line 20

0, in draw

self.initState(x,y) #this is the push()

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 86,

in initState

self.applyState()

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 80,

in applyState

self._canvas.setFont(sfontName?, sfontSize?)

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 358,

in setFont

_setFont(self._gs,fontName,fontSize)

File "C:\Python24\Lib\site-packages\reportlab\graphics\renderPM.py", line 238,

in _setFont

raise RenderPMError, "Can't setFont(%s) missing the T1 files?\nOriginally %s

: %s" % (fontName,s1,s2)
reportlab.graphics.renderPM.RenderPMError: Can't setFont(Times-Roman) missing the T1 files?
Originally exceptions.TypeError: makeT1Font() argument 2 must be string, not None

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Doesn't seem like a Django bug to me.

comment:2 Changed 5 years ago by PhiR

I've had a very similar bug with reportlab, and it was caused by having multiple interpreters instances in apache with mod_python. I've only found 2 ways of solving the problem: using a single interpreter per apache instance, or reducing the requests per child to 1 (which is suboptimal, performance-wise).

Hope that helps...

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.