Opened 8 years ago

Closed 3 years ago

Last modified 3 years ago

#4198 closed Bug (fixed)

admin javascript calendar spacing problem

Reported by: Gary Wilson <gary.wilson@…> Owned by: xian
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: fcurella Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: yes

Description

See the right edge of the calendar in the attached screen capture.

Setting the table's width to 100% seems to make the gap disappear (at least in Firefox on Linux).

  • django/contrib/admin/media/css/widgets.css

     
    4545.calendarbox, .clockbox { margin:5px auto; font-size:11px; width:16em; text-align:center; background:white; position:relative; }
    4646.clockbox { width:9em; }
    4747.calendar { margin:0; padding: 0; }
    48 .calendar table { margin:0; padding:0; border-collapse:collapse; background:white; width:99%; }
     48.calendar table { margin:0; padding:0; border-collapse:collapse; background:white; width:100%; }
    4949.calendar caption, .calendarbox h2 { margin: 0; font-size:11px; text-align:center; border-top:none; }
    5050.calendar th { font-size:10px; color:#666; padding:2px 3px; text-align:center; background:#e1e1e1 url(../img/admin/nav-bg.gif) 0 50% repeat-x; border-bottom:1px solid #ddd; }
    5151.calendar td { font-size:11px; text-align: center; padding: 0; border-top:1px solid #eee; border-bottom:none; }

So anyone know a reason why this needs to be 99%? Is this needed so that other browsers don't break?

Attachments (1)

4198.diff (436 bytes) - added by fcurella 3 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

doh, can't attach the screen capture due to http://trac.edgewall.org/ticket/4087, so here it is hosted elsewhere:

http://gdub.files.wordpress.com/2007/05/calendar.png

comment:2 Changed 8 years ago by Simon G. <dev@…>

  • Triage Stage changed from Unreviewed to Design decision needed

comment:3 Changed 7 years ago by ubernostrum

  • Owner changed from nobody to xian

Reassigning to xian.

comment:4 Changed 7 years ago by jacob

  • Triage Stage changed from Design decision needed to Accepted

comment:5 Changed 4 years ago by lrekucki

  • Severity set to Normal
  • Type set to Bug

comment:6 Changed 4 years ago by julien

  • UI/UX set

Changed 3 years ago by fcurella

comment:7 Changed 3 years ago by fcurella

  • Easy pickings set

Im confirming the incorrect displaying on Safari 5.1 Os X.

I've added a patch, basically just rewriting xian's fix as a diff.

Last edited 3 years ago by fcurella (previous) (diff)

comment:8 Changed 3 years ago by fcurella

  • Cc fcurella added

comment:9 Changed 3 years ago by jamesp

  • Triage Stage changed from Accepted to Ready for checkin

Confirmed fixed on Windows in IE 7, Firefox 5, Chrome, Safari

comment:10 Changed 3 years ago by julien

  • Resolution set to fixed
  • Status changed from new to closed

In [16822]:

Fixed #4198 -- Fixed a small styling issue in the admin calendar widget. Thanks to Gary Wilson and fcurella.

Note: See TracTickets for help on using tickets.
Back to Top