Code

Opened 7 years ago

Closed 7 years ago

#4178 closed (duplicate)

ImageField error when edited inline

Reported by: esauro@… Owned by: adrian
Component: contrib.admin Version: master
Severity: Keywords: ImageField, Admin interface
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When I try to use ImageField edited in line from Admin Interface I get this:

Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/django/core/handlers/base.py" in get_response
  77. response = callback(request, *callback_args, **callback_kwargs)
File "/usr/lib/python2.5/site-packages/django/contrib/admin/views/decorators.py" in _checklogin
  55. return view_func(request, *args, **kwargs)
File "/usr/lib/python2.5/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
  39. response = view_func(request, *args, **kwargs)
File "/usr/lib/python2.5/site-packages/django/contrib/admin/views/main.py" in change_stage
  329. new_object = manipulator.save(new_data)
File "/usr/lib/python2.5/site-packages/django/db/models/manipulators.py" in save
  165. if rel_new_data[related.opts.pk.name][0]:

  IndexError at /admin/micasa/casa/1/
  string index out of range

However when I don't use edit_inline the image is properly uploaded and stored. I think it's a BUG.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3519.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.