Opened 9 years ago

Closed 9 years ago

#4128 closed (duplicate)

Django 0.96 installation problem in Windows XP.

Reported by: zoltan.jose@… Owned by: adrian
Component: Tools Version: 0.96
Severity: Keywords: Install problem, Django 0.96, Windows XP
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by mtredinnick)

Hello good folks,

A short description - Django 0.96 does not install on Windows XP. The command " install" ( or " build" ) does not work... it gives the following error output:

running install
running build
running build_py
error: package directory '\django' does not exist

I hacked around a bit and found the problem in the file. The original relevant portion is:

# Compile the list of packages available, because distutils doesn't have
# an easy way to do this.
packages, data_files = [], []
root_dir = os.path.dirname(__file__)
len_root_dir = len(root_dir)
django_dir = os.path.join(root_dir, 'django')

I reckoned that the "root directory" was not being recognised properly... so I made the following change:

# Compile the list of packages available, because distutils doesn't have
# an easy way to do this.
packages, data_files = [], []
root_dir = "C:\\Django-0.96\\Django-0.96\\"     (NOTE: I manually added the 'root' directory pertinent to my system)
len_root_dir = len(root_dir)
django_dir = os.path.join(root_dir, 'django')

The above worked like magic without any hassles. So what's up guys, is this a bug or what? BTW, I had the latest installer tool :
setuptools-0.6c5-py2.5.exe installed in my system.

Thanks and Regards,

Timmy Jose (a.k.a z0ltan)

Change History (4)

comment:1 Changed 9 years ago by mtredinnick

  • Component changed from Admin interface to Tools
  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

(Fixed up wiki-formatting in summary.)

Can you print out what the value of __file__ is when you run Just put in a print statement before the line that sets root_dir. I'm trying to work out if __file__ is not set correctly or if os.path.dirname() is returning the wrong thing.

comment:2 Changed 9 years ago by mtredinnick

  • Description modified (diff)

comment:3 Changed 9 years ago by Simon G. <dev@…>

Duplicate of #4082 and #3245. I've closed those others as this looks like it has more info.

comment:4 Changed 9 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this since #3245 was re-opened and Malcolm has mentioned there that this was probably fixed as of [4912]. If someone can confirm this, please comment on #3245 and resolve that ticket as fixed.

Note: See TracTickets for help on using tickets.
Back to Top