Code

Opened 7 years ago

Closed 7 years ago

#4063 closed (duplicate)

Custom error messages for each fields

Reported by: ville.anttonen@… Owned by: adrian
Component: Forms Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Even it's nice that you have default validation/error messages (if you're american/english)
it would be better so that those could be overridden just like in the RegexField - field
with errormessage - parameter. If multiple errors could occur then messages could be defined
with dictionary for example.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 7 years ago by anonymous

See also #3457.

N.B. I think that the solution proposed in this ticket is much nicer.

comment:3 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3457.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.