Code

Opened 7 years ago

Closed 6 years ago

#4059 closed (invalid)

Adding django.contrib.databrowse to INSTALLED_APPS cause error.

Reported by: Jeong-Min Lee <falsetru@…> Owned by: adrian
Component: Contrib apps Version: 0.96
Severity: Keywords: databrowse
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

django.contrib.databrowse has no models.py

After adding django.contrib.databrwose to INSTALLED_APPS, running ./manage.py syncdb, ./manage.py runserver, ... raises following exception.

AttributeError: 'module' object has no attribute 'databrowse'

IMHO, following 2 solutions are possible.

  1. Adding models.py to django.contrib.databrowse
  2. Or modify documentation; remove following lines from docs/databrowse.txt
           * Add ``'django.contrib.databrowse'`` to your ``INSTALLED_APPS``
             setting. This will work if your ``TEMPLATE_LOADERS`` setting includes
             the ``app_directories`` template loader (which is the case by
             default). See the `template loader docs`_ for more.}}}
    

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by adrian

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

Hmmm, it works for me...

comment:2 Changed 7 years ago by Simon G. <dev@…>

Looks like it's a duplicate of #4058?

comment:3 Changed 6 years ago by Giuseppe

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from SVN to 0.96

Same problem this is my stack trace:

Traceback (most recent call last):
  File "./manage.py", line 11, in <module>
    execute_manager(settings)
  File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1672, in execute_manager
    execute_from_command_line(action_mapping, argv)
  File "/usr/lib/python2.5/site-packages/django/core/management.py", line 1564, in execute_from_command_line
    translation.activate('en-us')
  File "/usr/lib/python2.5/site-packages/django/utils/translation/trans_real.py", line 208, in activate
    _active[currentThread()] = translation(language)
  File "/usr/lib/python2.5/site-packages/django/utils/translation/trans_real.py", line 197, in translation
    default_translation = _fetch(settings.LANGUAGE_CODE)
  File "/usr/lib/python2.5/site-packages/django/utils/translation/trans_real.py", line 180, in _fetch
    app = getattr(__import__(appname[:p], {}, {}, [appname[p+1:]]), appname[p+1:])
AttributeError: 'module' object has no attribute 'databrowse'

If I set USE_I18N = False then I have this output when I run ./manage validate:

django.contrib.databrowse: No module named databrowse 1 error found

comment:4 Changed 6 years ago by ramiro

  • Resolution set to invalid
  • Status changed from reopened to closed

The databrowse app is not included with Django 0.96, it was added on r5011 whilst 0.96 was tagged on r4810.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.