Opened 8 years ago

Closed 8 years ago

#3967 closed (duplicate)

@cache_page(60 * 15) doesn't work, view = cache_page(view,60 * 15) does

Reported by: Henrik Vendelbo <info@…> Owned by: adrian
Component: Core (Other) Version: master
Severity: Keywords: middleware decorators
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I am trying to implement caching using the current dev version.

I get an AttributeError

/usr/lib/python2.4/site-packages/django/utils/decorators.py in _wrapped_view
line 12
/usr/lib/python2.4/site-packages/django/middleware/cache.py in process_request
line 47

'function' object has no attribute 'method'

Apparently the decorator passes a function in the request parameter

Change History (1)

comment:1 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #1015.

Note: See TracTickets for help on using tickets.
Back to Top