Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3927 closed (duplicate)

FastCGI Unhandled Exception

Reported by: cpghost@… Owned by: adrian
Component: django-admin.py runserver Version: master
Severity: Keywords: runfcgi fastcgi unhandled exception
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Running /usr/ports/www/py-django-devel (Django-20070214.tar.gz) on FreeBSD 6.2, I can't get FastCGI (with lighttpd) to run. The embedded (runserver) server works correctly, just runfcgi doesn't.

How to reproduce:


  1. Start lighttpd/fastcgi like this:

server.port = 85
fastcgi.server = ( "/" =>

( "localhost" =>

(

"host" => "127.0.0.1",
"port" => 10002,
"bin-copy-environment" =>
(

"PATH", "SHELL", "USER"

),
"broken-scriptfilename" => "enable",

)

)

)

  1. django-admin.py startproject mysite
  2. cd mysite
  3. python manage.py runfcgi method=threaded host=127.0.0.1 port=10002 daemonize=True

Now access http://127.0.0.1:85/ (Unhandled Exception - instead of the Django greeting page),
and http://127.0.0.1:85/blah (404, as expected).

Adding a view and mapping it with urls.py also results in 404.

Everything works just fine with runserver, but not with runfcgi.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 7 years ago by Gary Wilson <gary.wilson@…>

a double post of #3928, which was marked a duplicate of #3414.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.