Opened 8 years ago

Closed 8 years ago

#3918 closed (fixed)

Incorrect date/time display in admin/change history when USE_I18N = False

Reported by: Manuel Owned by: mtredinnick
Component: Internationalization Version: master
Severity: Keywords: i18n admin date time
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In Admin/Change history Date/time is not displayed correctly when USE_I18N is set to False in settings.py

See also forum.webfaction.com/viewtopic.php?pid=1850

Change History (4)

comment:1 Changed 8 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Confirmed as of r4921. Turning on USE_I18N makes it display properly. The problem is on line 26 in ../admin/templates/admin/object_history.html:

<th scope="row">{{ action.action_time|date:_("DATE_WITH_TIME_FULL") }}</th>

comment:2 Changed 8 years ago by mtredinnick

  • Owner changed from adrian to mtredinnick

comment:3 Changed 8 years ago by mtredinnick

  • Component changed from Admin interface to Internationalization

comment:4 Changed 8 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [4931]) Fixed #3918 -- Handle technical message IDs correctly when settings.USE_I18N is
False.

Note: See TracTickets for help on using tickets.
Back to Top