Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3868 closed (invalid)

traceback when trying to attach image file to ticket

Reported by: stereoit Owned by: jacob
Component: *.djangoproject.com Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi, today I tried to create ticket regarding favicon #3867 and when doing upload I got trac error:

Python Traceback

Traceback (most recent call last):

File "/home/trac/new-djangoproject-trac-test/trac/web/main.py", line 387, in dispatch_request
File "/home/trac/new-djangoproject-trac-test/trac/web/main.py", line 237, in dispatch
File "/home/trac/new-djangoproject-trac-test/trac/attachment.py", line 361, in process_request
File "/home/trac/new-djangoproject-trac-test/trac/attachment.py", line 475, in _do_save
File "build/bdist.linux-i686/egg/tracspamfilter/adapters.py", line 130, in validate_attachment
File "build/bdist.linux-i686/egg/tracspamfilter/api.py", line 131, in test
File "build/bdist.linux-i686/egg/tracspamfilter/model.py", line 119, in insert
File "/home/trac/new-djangoproject-trac-test/trac/db/util.py", line 50, in execute
File "/home/trac/new-djangoproject-trac-test/trac/db/util.py", line 50, in execute
File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 3083, in execute

parms = _quoteall(self.unicodeConvert(parms[0]))

File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 2300, in _quoteall

t = tuple(map(_quote, vdict))

File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 2268, in _quote

return PgQuoteString(value)

TypeError: PgQuoteString() argument 1 must be string without null bytes, not str

Not sure what can I do about it.

Change History (2)

comment:1 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from error in trac to traceback when trying to attach image file to ticket

I have opened a ticket in Trac's ticket system: http://trac.edgewall.org/ticket/5061

Marking this invalid since it not related to Django.

comment:2 Changed 8 years ago by Gary Wilson <gary.wilson@…>

Above ticket marked as a duplicate of this one.

Note: See TracTickets for help on using tickets.
Back to Top