Opened 8 years ago

Closed 8 years ago

#3761 closed (duplicate)

feeds.py should allow user set guid tag

Reported by: spark343@… Owned by: adrian
Component: contrib.syndication Version: master
Severity: Keywords: guid,
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

/django/contrib/syndication/feeds.py specifies the RSS item guid property to be identical to link. guid, by RSS 2 specification must be a *UNIQUE* id for the rss item. However, it is quite possible that multiple items in the feed will have the same link. Leaving the default for guid to be the same as item is fine, but there should definitely be code to allow the developer to override using the same style as the other feed properties:

def item_guid(self, item):

Change History (2)

comment:1 Changed 8 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed
  • Version changed from 0.95 to SVN

comment:2 Changed 8 years ago by Simon G. <dev@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Oops. Dupe of #3760 which has a patch

Note: See TracTickets for help on using tickets.
Back to Top