Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3704 closed (duplicate)

Localization stuff & humanize improvements

Reported by: Baptiste Owned by: jacob
Component: Uncategorized Version: master
Severity: Keywords: internationalization, humanize
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This patch fixes some strings that xgettext didn't like, and allows the localisation of contrib.humanize. It adds also the option "--from-code UTF-8" to the xgettext command line (in bin/make-messages.py), to solve a little encoding issue.

This patch adds the support of exponents in contrib.humanize.ordinal.

{{ value|ordinal:True }}

will output :

1<sup>st</sup>

By default, no change, but that can be helpful.

Attachments (2)

patch.diff (6.1 KB) - added by Baptiste <baptiste.goupil@…> 8 years ago.
patch.2.diff (6.1 KB) - added by Baptiste <baptiste.goupil@…> 8 years ago.
Oops, there was a little issue

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Baptiste <baptiste.goupil@…>

Changed 8 years ago by Baptiste <baptiste.goupil@…>

Oops, there was a little issue

comment:1 Changed 8 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

The first part is a dupe of #3410, which I am just about to commit. The second part is a wontfix. If you want customisations like that -- and there are so many possibilities that we cannot accommodate everybody, so we take a fairly minimalist line -- it's easy enough to write your own filter.

Please file one issue per ticket in the future. It's makes triaging/resolving much easier.

comment:2 Changed 8 years ago by mtredinnick

I've ended up taking part of this patch, too, since you caught the plural problem in the humanize filters.

comment:3 Changed 8 years ago by mtredinnick

(In [4704]) Fixed #3410 -- Edited a few i18n markups for completeness and to remove some
warnings from recent gettext versions. Refs #3704. Thanks, Michael Radziej,
mirrorballu2@… and baptiste.goupil@….

Note: See TracTickets for help on using tickets.
Back to Top