Code

Opened 7 years ago

Closed 7 years ago

#3675 closed (duplicate)

Request: subclassing in model , abstract classes

Reported by: atomekk Owned by: adrian
Component: Core (Other) Version: master
Severity: Keywords:
Cc: atomekk@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have request to add feature to Django that will allow subclassing of db model. For egzample i have UML class diagram from which i must build DB model and some of the classes are 'abstract' ones (inherits from another) so to sum up this feature is needed at least for me (or maybe for others users too).

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I'm pretty sure this is a duplicate, but can't find another ticket that refers specifically to model inheritance/subclassing.

There is some information on the ModelInheritance wiki page, though I don't know what the current development state of this is. The version one features list indicates that this functionality is intended to be present in Django version 1.

comment:2 Changed 7 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1656; it is being worked on.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.