Code

Opened 7 years ago

Closed 7 years ago

#3652 closed (worksforme)

ChoiceField formfield for IntegerField and CharField

Reported by: Øyvind Saltvik <oyvind.saltvik@…> Owned by: cogg
Component: Forms Version: master
Severity: Keywords: newforms choicefield integerfield charfield
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: UI/UX:

Description

Patch for choicefields for model fields with choices.

Attachments (2)

4664-choicefield.patch (3.7 KB) - added by Øyvind Saltvik <oyvind.saltvik@…> 7 years ago.
ChoiceField patch
6213-choicefield-test-only.patch (1.4 KB) - added by cogg 7 years ago.
Only the unit test portion of patch against current version of trunk

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Øyvind Saltvik <oyvind.saltvik@…>

ChoiceField patch

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Accepted

I'm not keen on how this changes ChoiceField, but I like the overall idea...

comment:2 Changed 7 years ago by cogg

  • Owner changed from nobody to cogg

Changed 7 years ago by cogg

Only the unit test portion of patch against current version of trunk

comment:3 follow-up: Changed 7 years ago by cogg

I am not sure what was intended here, but it appears the requested functionality is already present because running the supplied test against the current trunk succeeds. I think this ticket should be closed as fixed or more explanation should be provided.

comment:4 in reply to: ↑ 3 Changed 7 years ago by ubernostrum

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to cogg:

I am not sure what was intended here, but it appears the requested functionality is already present because running the supplied test against the current trunk succeeds. I think this ticket should be closed as fixed or more explanation should be provided.

Agreed; this seems to cover something that already works. If anyone can explain why this isn't so, please re-open with a more specific explanation.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.