Opened 7 weeks ago

Closed 7 weeks ago

#35398 closed Bug (duplicate)

If the JSONField contains numbers key, the hash_key query becomes invalid

Reported by: hanjiangxue20 Owned by: nobody
Component: Database layer (models, ORM) Version: 3.0
Severity: Normal Keywords:
Cc: hanjiangxue20 Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by hanjiangxue20)

The JSONField defined in the django model contain numbers, such as fields: tags value is {"123": "abc"}, and querying XX.objects.filter (tagshas_key='123') is invalid! get nothing.

Change History (3)

comment:1 by hanjiangxue20, 7 weeks ago

Description: modified (diff)

comment:2 by willzhao, 7 weeks ago

can you elaborate on this issue and provide a minimal reproducible case?

comment:3 by Sarah Boyce, 7 weeks ago

Resolution: duplicate
Severity: Release blockerNormal
Status: newclosed

Duplicate of #33552 and fixed as of 4.1 (note that 3.0 is no longer supported)

Note: See TracTickets for help on using tickets.
Back to Top