Opened 8 years ago

Closed 7 years ago

#3539 closed (fixed)

LANGUAGE_CODE settings are ignored

Reported by: joerg@… Owned by: nobody
Component: Core (Other) Version: 0.95
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When using Django with runfcgi the language settings (settings.LANGUAGE_CODE) are get overriden.

Initially the correct files are loaded, but afterwards reset to en-us. This does not happen with runserver.

The culprit seems to be django.core.management.execute_from_command_line, which forcefully sets the language for most actions.
Commenting the call to translation.active out results in the expected behaviour.

Change History (6)

comment:1 Changed 8 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 8 years ago by mtredinnick

Is #4813 the same problem in another disguise?

comment:3 Changed 7 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 7 years ago by mir

  • Resolution fixed deleted
  • Status changed from closed to reopened

I don't trust anonymous closers - is this really closed?

comment:5 Changed 7 years ago by joerg@…

Yes. Doesn't happen any longer and the sister bugs are closed already.

comment:6 Changed 7 years ago by Simon Greenhill

  • Resolution set to fixed
  • Status changed from reopened to closed

Ok, reclosing.

Note: See TracTickets for help on using tickets.
Back to Top